[CentOS] yum で ruby をインストールする。

ruby を使いたくなったので CentOS 6.6 にインストールしました。

$ yum install ruby.i686
読み込んだプラグイン:fastestmirror
このコマンドを実行するには root である必要があります。
$ sudo yum install ruby.i686
[sudo] password for keramax:
読み込んだプラグイン:fastestmirror
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
* base: www.ftp.ne.jp
* extras: www.ftp.ne.jp
* updates: www.ftp.ne.jp
base | 3.7 kB 00:00
extras | 3.4 kB 00:00
updates | 3.4 kB 00:00
依存性の解決をしています
–> トランザクションの確認を実行しています。
—> Package ruby.i686 0:1.8.7.374-4.el6_6 will be インストール
–> 依存性の処理をしています: ruby-libs = 1.8.7.374-4.el6_6 のパッケージ: ruby-1.8.7.374-4.el6_6.i686
–> 依存性の処理をしています: libruby.so.1.8 のパッケージ: ruby-1.8.7.374-4.el6_6.i686
–> トランザクションの確認を実行しています。
—> Package ruby-libs.i686 0:1.8.7.374-4.el6_6 will be インストール
–> 依存性の処理をしています: libreadline.so.5 のパッケージ: ruby-libs-1.8.7.374-4.el6_6.i686
–> トランザクションの確認を実行しています。
—> Package compat-readline5.i686 0:5.2-17.1.el6 will be インストール
–> 依存性解決を終了しました。依存性を解決しました============================================================================================================================
パッケージ アーキテクチャ バージョン リポジトリー 容量
============================================================================================================================
インストールしています:
ruby i686 1.8.7.374-4.el6_6 base 538 k
依存性関連でのインストールをします。:
compat-readline5 i686 5.2-17.1.el6 base 128 k
ruby-libs i686 1.8.7.374-4.el6_6 base 1.6 Mトランザクションの要約
============================================================================================================================
インストール 3 パッケージ総ダウンロード容量: 2.3 M
インストール済み容量: 7.8 M
これでいいですか? [y/N]y
パッケージをダウンロードしています:
(1/3): compat-readline5-5.2-17.1.el6.i686.rpm | 128 kB 00:00
(2/3): ruby-1.8.7.374-4.el6_6.i686.rpm | 538 kB 00:00
(3/3): ruby-libs-1.8.7.374-4.el6_6.i686.rpm | 1.6 MB 00:01
—————————————————————————————————————————-
合計 901 kB/s | 2.3 MB 00:02
rpm_check_debug を実行しています
トランザクションのテストを実行しています
トランザクションのテストを成功しました
トランザクションを実行しています
インストールしています : compat-readline5-5.2-17.1.el6.i686 1/3
インストールしています : ruby-libs-1.8.7.374-4.el6_6.i686 2/3
インストールしています : ruby-1.8.7.374-4.el6_6.i686 3/3
Verifying : ruby-1.8.7.374-4.el6_6.i686 1/3
Verifying : compat-readline5-5.2-17.1.el6.i686 2/3
Verifying : ruby-libs-1.8.7.374-4.el6_6.i686 3/3

インストール:
ruby.i686 0:1.8.7.374-4.el6_6

依存性関連をインストールしました:
compat-readline5.i686 0:5.2-17.1.el6 ruby-libs.i686 0:1.8.7.374-4.el6_6

完了しました!
$ which ruby
/usr/bin/ruby
$ ruby -v
ruby 1.8.7 (2013-06-27 patchlevel 374) [i386-linux]
$

yum にまかせていたらバージョン 1.8.7 の ruby がインストールされてしまった。

しばらくはこれで行こうと思う。

(Visited 720 times, 1 visits today)

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください